System Requirements

The following applications are supported by the system requirements in the tables below:

  • OpenCCC Student Account System
  • CCCApply Standard Application
  • CCCApply International Application
  • CC Promise Grant Application
  • CCC Administrator (CAP)
  • CCCApply Administrator 2.0
  • CCC Report Center 

Java Version

As of March 11, 2016, Java 7 is required for the latest Download Client. You can download Java 7:

http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html

Supported OS / Browsers

Supported: The most current version and one version back.

OS Version

Browser

Windows 7 and 8.1Chrome
OS X: Yosemite (v10.10) and Mavericks (v10.9)Chrome


Supported OS / Browsers / Screen Readers

OS Version

Browser

Accessibility Screen Reader
Windows 7 and 8.1

IE 10 and 11 (Windows 7), IE 11 (Windows 8.1)

Jaws
Windows 7 and 8.1ChromeNot supported at this time
AndroidChromeJaws
OS X: Yosemite (v10.10) and Mavericks (v10.9)SafariVoiceOver



Please report any issues found using the OS/browser/Accessibility combinations above via CCCTechnology.info.



Download Client System Requirements

  • A Virtual Machine dedicated for the Download Client installation
  • Java 7 or higher of either the Java Runtime Environment (JRE) or Java Development Kit (JDK)
  • The latest Download Client version, available here (as a transfer-client.jar file): https://cccnext.jira.com/wiki/ display/PD/User+Guides

The most recent Download Client version and one version back are officially supported for each major CCCApply release.


If you experience issues downloading your application data after a major release, use the following steps to determine your Download Client version:

  1. Type the following command at the ../transfer-client/ command prompt:

    1. java -jar transfer-client.jar --version
      • If you have Download Client V5.4.0 installed, this will display: VERSION: 2016-03-08 12:35:19, 1.0-

    SNAPSHOT

      • If you have Download Client V5.3.0 installed, this will display: VERSION: 2015-10-16 16:00:27, 1.0-

    SNAPSHOT 2


     
  2.  If you have a Download Client version that is prior to V5.3.0, an error displays. You can upgrade to the latest Download Client version available here (transfer-client.jar file):

https://cccnext.jira.com/wiki/display/PD/User+Guides

•     The steps that follow assume the ‘java’ and ‘jar’ commands are available from your PATH environment. The installers for both the JRE and JDK should install the Java runtime so that the various command-line tools, including ‘java’ and ‘jar’ are available in the system PATH.